16 августа 2010 г.

Установка приложения на устройство с прошивкой 3.х из Xcode 3.2.4

Аpple из новых версий Xcode убрали iPhone Simulator версий 2.х и 3.х. Так же базовой версией SDK можно поставить только версии 4.х. Не обязательно держать установленным две версии Xcode для поддержки из вашего приложения версий 3.х и 4.х. Из новой версии Xcode можно устанавливать приложения на устройства с прошивкой 3.0, для этого нужно в свойствах проекта выставить свойство "iOS Deployment Target" на нужную версию SDK вашего устройства.

По комментариям статьи.

PS: перед использованием функций которых нет в более ранних версиях SDK следует проверять их наличие

  1. if ([obj respondsToSelector:@selector(someSelector:)])
  2. {
  3.   [obj performSelector:self withObject:nil];
  4. }

Комментариев нет:

Отправить комментарий